UnionCreated using FigmalectureCreated using Figma
1114 https://ppc.world/build/resources/img/logo-v2.png Изменения вступят в силу 1 апреля 2020 года 2020-03-11 ppc.world 160 31 Новость 1

Google Ads API запретит создавать рекламу приложений для вовлечения в некоторых приложениях

С 1 апреля 2020 года через Google Ads API нельзя будет создавать рекламу приложений для вовлечения (App engagement campaigns) в запрещенных категориях приложений. 

Сейчас через API можно создавать рекламу приложений для вовлечения в любой категории приложений. Но если выбрано приложение из запрещенной категории, показы рекламы будут запрещены, сообщается в блоге разработчиков Google.

Теперь в API заработает предварительная проверка, благодаря которой разработчики смогут исправить ошибки еще на этапе создания кампании, а также гарантирует, что объявления будут показываться.

Реклама приложений для вовлечения идентифицируются в API как объекты кампании со следующими свойствами.

  • Advertising_channel_type: MULTI_CHANNEL

  • Advertising_channel_sub_type: APP_CAMPAIGN_FOR_ENGAGEMENT

Когда обновление вступит в силу, вызовы API для создания кампаний вышеуказанного типа завершатся ошибкой, если app_campaign_setting.app_id кампании ссылается на приложение из запрещенной категории.

Google Ads API v3 и более поздние будут выдавать ошибку SENSITIVE_CATEGORY_APP. Более ранние версии API будут генерировать общую неизвестную ошибку (UNKNOWN), поскольку код ошибки не публикуется в этих версиях. Эти ошибки могут возникать из-за следующих операций и сервисов:

Версия API Сервис Операция Ошибка
v3+ CampaignService create CampaignError.SENSITIVE_CATEGORY_APP
v1, v2 CampaignService create CampaignError.UNKNOWN

Для случаев с кодом ошибки CampaignError.UNKNOWN в поле details.unpublished_error_code для GoogleAdsError будет указано «CampaignError.SENSITIVE_CATEGORY_APP».

Если вы создаете рекламу приложений для вовлечения через API, добавьте обработку ошибок для приложений в запрещенных категориях. Чтобы использовать новую ошибку SENSITIVE_CATEGORY_APP, сначала обновите до версии Google Ads API v3.

Если вы не можете обновить версию, проверьте код ошибки CampaignError.UNKNOWN при создании кампании и убедитесь, что строка ошибки details.unpublished_error_code соответствует имени ошибки, задокументированному в предыдущем разделе. Это указывает на то, что в кампании, вероятно, используются приложения из запрещенной категории. 

Чтобы узнать подробности, ознакомьтесь с руководством. Если у вас возникли вопросы, обращайтесь на форум разработчиков.

Напомним, что в конце февраля Google анонсировал бета-версию Google Ads API v3_0.

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: